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Statement 

1. Implementation. The softwares of the CUCKOO Workgroup are implemented in 

JAVA (J2SE). Usually, both of online service and local stand-alone packages will be 

provided.  

2. Availability. Our softwares are freely available for academic researches. For 

non-profit users, you can copy, distribute and use the softwares for your scientific 

studies. Our softwares are not free for commercial usage.  

3. GPS. Previously, we used the GPS to denote our Group-based Phosphorylation 

Scoring algorithm. Currently, we are developing an integrated computational platform 

for post-translational modifications (PTMs) of proteins. We re-denote the GPS as 

Group-based Prediction Systems. This software is an indispensable part of GPS.  

4. Usage. Our softwares are designed in an easy-to-use manner. Also, we invite you to 

read the manual before using the softwares.  

5. Updation. Our softwares will be updated routinely based on users’ suggestions and 

advices. Thus, your feedback is greatly important for our future updation. Please do not 

hesitate to contact with us if you have any concerns.  

6. Citation. Usually, the latest published articles will be shown on the software 

websites. We wish you could cite the article if the software has been helpful for your 

work.  

7. Acknowledgements. The work of CUCKOO Workgroup is supported by grants 

from Chinese 973 project (2002CB713700, 2006CBOF0503, and 2006CB933300), 

Chinese Academy of Sciences (KSCX1-YW-R65, KSCX2-YW-21, and 

KJCX2-YW-M02), Chinese Natural Science Foundation (39925018, 30270293, 

90508002, 30700138) and National Institutes of Health (DK56292).  
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Introduction 

The graphical representation of biological sequences is fundamental for the 

efficient interpretation of scientific achievements in the research of biochemistry and 

molecular biology. Schematic diagram with biological sequences drawing in an 

aesthetic and illustrative way is not only crucial for the publication of scientific works, 

but also important for academic exchanges. Therefore, the drawing of biological 

sequences is now becoming one of the essential skills for biology researchers. 

Generally, the Microsoft PowerPoint, Adobe Illustrator and Photoshop are three 

pieces of widely-used software that can assist the preparation of biological diagram. 

However, due to the complexity, it will take quite some time to be familiar with their 

operation. Besides, the scale of a schematic diagram generated by these tools is 

usually approximate. When drawing with those tools, neither the locations of 

functional domains nor the positions of functional sites can be precisely designated in 

the biological sequences.  

 

Early in 2009, our research group have developed a novel software called 

Domain Graph 1.0 (DOG 1.0) for helping the presentation of protein functional 

domain. Up to May, 2014, DOG 1.0 was cited by 62 published works and assisted 

numerous researchers in preparing their research achievements. However, as DOG 1.0 

was specifically designed for protein presentation, it may be inconvenient for 

illustrating nucleotide diagram. Also, the nucleotide diagram drew by DOG 1.0 may 

usually not satisfy the general style. Thus, development of a new software that not 

only apply to protein domain graph preparation but also to nucleotide presentation 

will be necessary for the community.  

 

In this work, we present a brand new tool called IBS 1.0 for assisting 

experimentalists in drawing high-quality schematic diagram of biological sequences. 

With a dual-mode user interface, experimentalists are allowed to produce their own 

schematic diagram for both protein and nucleotide sequences in a convenient manner. 

To provide a drawing environment without restriction, abundant graphical elements, 

such as polygon, bracket, curve and polyline, were available. Furthermore, drawing 

under our professional renderers, the schematic diagrams will be generated in a more 

aesthetic and concise appearance. 
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Download & Installation 

The IBS 1.0 software was implemented in JAVA 1.6 (J2SE 6.0), and could be installed 

on three major Operating Systems (OS), including Windows, Linux/Unix or Mac OS 

X systems. The local stand-alone packages of IBS 1.0 can be freely available at 

http://dog.biocuckoo.org/software.php. We recommend that users could download the 

latest release.  

 

Please choose the proper package to download. After downloading, please 

double-click on the software package to begin installation, following the user prompts 

through the installation. The snapshots of the setup program for windows are shown 

below: 
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Finally, please click on the Finish button to complete the setup program. 
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The IBS work environment 

Startup Interface 

In IBS 1.0, a dual-mode user interface was developed. After the initial startup of IBS 

1.0, a selection dialog appears as below. Through this dialog, you can choose to work 

in either protein mode or nucleotide mode. 

 

 

Protein mode is activated. 
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Nucleotide mode is activated 

 

After choosing the working mode, IBS activates the work environment, including the 

Canvas, Console panel, Component List, Shape toolbar and Menus. Also, there are 

several protein and nucleotide examples included in the software. Randomly, two 

schematic diagrams were selected as below: 
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The instance for protein mode 
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The instance for nucleotide mode 

 

Canvas 

Display the graph of the current project.  

You can use the keyboard UP/DOWN or mouse Wheel Up/Wheel Down to zoom 

in/out the graph. You can also use the right-Click popup menu to adjust the graph. 

 

Console 

This panel contains five option buttons for drawing protein or nucleotide domain 

structures. 

 

The console panel in protein mode 

 

The console panel in nucleotide mode 

 

1. Protein (or Nucleotide) button: Define the basic properties of the current protein 

(or Nucleotide). 

2. Domain button: Add a functional domain to the current protein (or Nucleotide). 

3. Site button: Add short motif or functional site to the current protein (or 

Nucleotide). 

4. Cut Line button: add cut elements, add cut effect on protein (or nucleotide). 

5. Note button: Add comments of the current protein (or nucleotide). 

6. Zoom drop-down box: Select a zoom ratio for the canvas.  

7. Grayscale checkbox: When selected, the image turn into a grayscale image. 

Conversely, color image. 
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Component List 

List all the components of the current project, including protein, domain, site and note. 

Different components could be marked in different colors and major properties. 

 

You can use the Right-Click popup menu to edit, delete or insert a new component 

before the selected component.  

 

You can also double click a component to edit it. 

 

The shape toolbar 

The basic operational commands and commonly-used drawing elements are included 

in the toolbar.  

 

1. Undo : Undo the last operation. 

2. Redo : Redo the previous operation. 

3. Note : Add note. 

4. Marker : Draw polygon marker. 

5. Bracket : Draw square and braces bracket. 

6. Straight Line : Draw a straight line. 

7. Curve : Draw a curve with one control point. 

8. Polyline with two knuckle point : Draw a polyline with two knuckle points. 

9. Bezier curve : Draw a Bezier curve with two control points. 
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10. Polyline with one knuckle point : Draw a polyline with on knuckle point. 

 

Menus 

File Menu 

 

 

New project  

Open a new and untitled IBS project.  

 

Open project  

Display a dialog box allowing you to open an existing IBS project file and display the 

contents in a new canvas.  

 

Save  

Save the contents of the current project in XML format as a file in the current 

directory or folder on the disk. If this is the first time that you are saving the file, you 

must enter a file name. If the file has been saved before, the existing file name is used.  

 

Caution: The Save command will overwrite any file with the same name that is in the 

same directory or folder! If you do not want to do this, choose File -> Save As and 

give the file a different name.  

 

Save As…  

Display a dialog box allowing you to save the contents of the current project in XML 

format as a file, with a file name that you provide.  

 

Export Image 
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Export image in PNG, JPEG,TIFF or SVG format to a file on the disk.  

 

Exit 

Close the current project and exits the current IBS session. A dialog asks if you want 

to save or abandon the changes, or cancel the command. 

 

Edit menu 

Edit menu in protein mode 

 
 

Edit menu in nucleotide mode 
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Add Protein 

Add a new protein.  

 

Add Nucleotide 

Add a new nucleotide. 

 

Add Domain  

Add a functional domain to the current protein or nucleotide. 

 

Add Site  

Add short motif (usually<15aa/bp) or functional site to the current protein or 

nucleotide. 

 

Add Note 

Add name of the current protein or nucleotide. 

 

Add Bracket 

Add a bracket to the current protein or nucleotide sequence. 

 

Add Straight Line 

Add a straight line to the current protein or nucleotide sequence. By double-clicking 

the element, the style of straight line can change to arrow, double arrow, scale arrow 

or double-scale arrow. 

 

Add Curve 

Add a curve with one control point to the current protein or nucleotide sequence. By 

double-clicking the element, the style of curve can be change to arrow, double arrow, 

scale arrow or double-scale arrow. 

 

Add Bezier Curve 

Add a bezier curve with two control points to the current protein or nucleotide 

sequence. By double-clicking the element, the style of Bezier curve can be change to 

arrow, double arrow, scale arrow or double-scale arrow. 

 

Add Polyline with Two Knuckle Points 

Add a polyline curve with two control points to the current protein or nucleotide 

sequence. By double-clicking the element, the style of polyline can be change to 

arrow, double arrow, scale arrow or double-scale arrow. 

 

Add Polyline with One Knuckle Point 

Add a polyline curve with one knuckle point to the existing protein or Nucleotide 

sequence. By double-clicking the element, the style of polyline can be change to 
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arrow, double arrow, scale arrow or double-scale arrow. 

 

Add Line 

Add lines of 4 types: Line, Arrow, Double Arrow, Scale. 

 

Canvas size 

Set the size of current canvas. 

 

Undo 

Undo the last operation. 

 

Redo 

Redo the previous operation. 

 

Tool menu 

 

 

Demo  

We randomly re-drew domain graphs for 35 distinct proteins and several 

nucleotides from four journals, including Cell, Nature Cell Biology (NCB), The 

Journal of Cell Biology (JCB), Molecular Biology of the Cell (MBC) and Molecular 

and Cellular Biology (MCB). These instances could be browsed software demos. 
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Batch Export Images  

With this tool, you can batch export images form IBS projects into JPG(72dpi), 

PNG(72dpi), TIFF(300/600dpi) or SVG(vector image) format. 

 

 

Image Format  

With this tool, you can convert image in JPG, PNG or GIF format to TIFF format 

with a resolution of 300-1200dpi.  
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Batch Export Images in Command Line 

You can also use the command line version to batch export images from IBS projects. 

Five different types of image formats, such as JPG(72dpi), PNG(72dpi), 

TIFF(300/600dpi), SVG(vector image), are supported in the command line. When 

you are exporting image in high resolution (under 300 or 600 dpi), pleasure 

ensure that the physical memory in your computer are of sufficient size. To 

guarantee a proper functionality, you need at least 512M memory. 

Export Images with a Configuration File 

To batch export images in the command line, you can provide a configuration file that 

specify detail parameters. The syntax of the configuration file are describe below: 

 

xmlpath: The directory that contains a set of IBS project files (xml format). 

Picpath: The directory where you want to export the image to. 

format: The output format. The following formats are support: 

  A:JPG (72dpi),    

  B:PNG (72dpi),     

  C:TIFF (300dpi),  

  D:TIFF (600dpi),    

  E:SVG (vector image)    

unit: The unit type. Four unit types (pix, cm, mm, inch) are allowed. 

width: The width of the output image. 

heigh: The height of the output image. 

ratio: Whether to keep the ratio of width/height while exporting the image. 

TRUE/FALSE are allowed. 
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Here is an example for the configuration file: 

 

 

You can use the following command to begin the exportation: 

 

Where –Xmx sets the maximum memory heap size, -c sets the location of a 

configuration file. 

NOTE: A minimal memory of 512 MB is required while exporting high 

resolution image. 

 

Export Image without Configuration File 

You can also export the IBS projects in command line without using the configuration 

file. The detail commands are presented below: 

 

-x: The directory that contains a set of IBS project files (xml format). 

-p: The directory where you want to export the image to. 

-f: The output format. The following formats are support: 

   A:JPG (72dpi), 

   B:PNG (72dpi), 

   C:TIFF (300dpi), 

   D:TIFF (600dpi), 

   E:SVG (vector image) 

-u: The unit type. Four unit types (pix, cm, mm, inch) are allowed. 

-w: The width of the output image. 

-h: The height of the output image. 

-r: Whether to keep the ratio of width/height while exporting the image. 

TRUE/FALSE are allowed. 

 

Here is an example for the command line: 

 

xmlpath = demo/nucleotide 

picpath = output 

format = D 

unit = cm 

width = 18 

height = 14 

ratio = false 

java –jar –Xmx 512m IBS.jar –c Config.txt 

java -jar -Xmx512m IBS.jar -x demo/nucleotide -p output -f D -u cm -w 25 -h 18 -r false 
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Where –Xmx sets the maximum memory heap size. Note that, a minimal memory 

of 512 MB is required while exporting high resolution image. 

All the help information can be seen and printed using the following command: 

 

java –jar IBS.jar –help 

java –jar IBS.jar –h 
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Illustration of Protein and Nucleotide Domain 

Structures 

New Protein 

When you click on the Protein button or choose Edit -> Add Project, a new protein 

feature dialog box will appear as shown below: 

 

The right area of the property dialog box contains the following settings for the 

protein: 

 

1. The ID panel 

ID: A unique ID can be indicated for the current element in this textfield. When 

the element is created, a default ID value will be automatically indicated. Users is 

allow to modify the default value. When inputting a new value, the characters will 

turn black from gray. 

 

2. The position panel 

Start: Assign a start position for the protein sequence. 
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End: Assign an end position for the protein sequence. 

Height: Assign the height for the protein sequence. Default value is 25. 

Vertical: The vertical offset to the center of the current canvas. 

Horizontal: The horizontal offset to the center of the current canvas. 

Locked: A checkbox for restricting the horizontal movement of a protein 

sequence. When the option is selected, a horizontal movement is prohibited. 

 

3. The style panel 

Color: Select a color for the current protein from the chooser dialog. 

Gradient: Select a color gradient for the current protein. 

Texture: Select a texture for the current protein. 

Font Size: Select the font size of the position number. 

 

4. The border panel 

Line size: Change the border size of the current protein. 

Dash: A checkbox for altering the border line into dash line. 

Line color: Select a color for the border line from the chooser dialog. 

 

Note: For convenience, the “Preview” panel shows the effect of current figure. 

 

The IBS version 1.0 supports multi-protein display. You can add two or more proteins 

in a canvas. 
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New Nucleotide 

When you click on the Nucleotide button or choose Edit -> Add Nucleotide, a new 

nucleotide feature dialog box will appear as shown below: 

 

As shown in the nucleotide feature dialog, the settings for nucleotide sequence were 

identical to protein mode. 
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Similarly, the nucleotide mode interface supports multi-nucleotide display. You can 

add two or more nucleotides in a canvas. 

 

Add Domain (In protein mode) 

When you click the Domain button or choose Edit -> Add Domain in protein mode 

interface, a domain property dialog box will appear as shown below: 
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The right area of the property dialog box contains the following settings for the 

domain: 

 

1. The ID panel 

ID: A unique ID can be indicated for the current domain in this textfield. When 

the domain is created, a default ID value will be automatically indicated. Users is 

allow to modify the default value. When inputting a new value, the characters will 

turn black from gray. 

 

2. The position panel 

Start: Assign a start position for the protein domain. 

End: Assign an end position for the protein domain. 

 

3. The text panel 

Name: Name of the domain. 

Location: A combo box to set the name of domain display above, under or inside 

the domain or not display at all. 

Font: Select the font size of the domain name. 

Text Color: Select the font color of the domain name. 

 

4. The style panel 

Color: Select a color for the current domain from the chooser dialog. 
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Gradient: Select a color gradient for the current domain. 

Texture: Select a texture for the current domain. 

 

5. The border panel 

Line size: Change the border size of the current domain. 

Dash: A checkbox for altering the border line into dash line. 

Line color: Select a color for the border line from the chooser dialog. 

 

Note: 

 

You can use the position direction combo box to set the start and end position texts 

display above or under the domain or not display at all. 

Down:  

 

Up:  

 

Hide:  

 Use the name location combo box to set the name of domain display 

above, under or inside the domain or not display at all. 

Center:  

 

Up:  
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Down:  

 

Hide:  

 

Add Domain (In nucleotide mode) 

When you click the Domain button or choose Edit -> Add Domain in protein mode 

interface, a domain property dialog box will appear as shown below: 

 

The right area of the property dialog box contains the following settings for the 

domain: 

 

1. The ID panel 

ID: A unique ID can be indicated for the current domain in this textfield. When 

the domain is created, a default ID value will be automatically indicated. Users is 

allow to modify the default value. When inputting a new value, the characters will 

turn black from gray. 
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2. The position panel 

Start: Assign a start position for the nucleotide domain. 

End: Assign an end position for the nucleotide domain. 

Height: Assign the height for the nucleotide domain. There is no such option in 

protein mode.  

 

3. The style panel 

Shape: The functional domains in nucleotide are represented as polygons. The 

shape combo box allows the users selecting various polygon elements for 

nucleotide domain representation. 

Rotation Angle: Specify a rotation angle for the nucleotide domain. 

Shape Color: Select a color for the current domain from the chooser dialog. If the 

default check box is selected, the software will assign a default color for the 

domain element.  

Gradient: Select a color gradient for the current domain. 

Texture: Select a texture for the current domain. 

 

4. The text panel 

Name: Name of the domain. 

Location: A combo box to set the name of domain display above, under or inside 

the domain or not display at all. 

Font: Select the font size of the domain name. 

Text Color: Select the font color of the domain name. 

 

5. The border panel 

Line size: Change the border size of the current domain. 

Dash: A checkbox for altering the border line into dash line. 

Line color: Select a color for the border line from the chooser dialog. 

 

Note:  

 

You can use the position direction combo box to set the start and end position 

texts display above or under the domain or not display at all.  

Down:  



IBS Manual 

 

30 

 

 

Up:  

 

Hide:  

 

 

Use the name Location combo box to set the name of domain display above, 

under or inside the domain or not display at all.  

Center:  

Up:  

 

 

Down:  

 

Hide:  

 

Add Site 

When you click the Site button or choose Edit -> Add Site in both protein mode and 

nucleotide mode, a site property dialog box will appear as shown below: 
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The right area of the property dialog box contains the following settings for the site: 

 

1. The ID panel 

ID: A unique ID can be indicated for the functional site in this textfield. When the 

functional site is created, a default ID value will be automatically indicated. Users 

is allow to modify the default value. When inputting a new value, the characters 

will turn black from gray. 

 

2. The site panel 

Position(s): Specify the exact positions of functional sites.  

 

3. The text panel 

Name: Text of the site. 

Font Size: Select the font size of the text. 

Text Color: Select the font color of the text. 

 

4. The location panel 

Central X: Set the x coordinate for the position text. 

Central Y: Set the y coordinate for the position text. 
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5. The style panel 

Shape: The functional sites can be represented as polygons. With this shape 

combo box, users are allow to select various polygon elements for functional sites 

representation.  

Rotation Angle: Specify a rotation angle for the functional sites. 

Shape Color: Select a color for the current sites from the chooser dialog. If the 

default check box is selected, the software will assign a default color for the site 

element.  

Gradient: Select a color gradient for the current site. 

Texture: Select a texture for the current site. 

Width: Assign the width of the functional site. 

Height: Assign the height of the functional site. 

 

6. The border panel 

Line size: Change the border size of the current site. 

Dash: A checkbox for altering the border line into dash line. 

Line color: Select a color for the border line from the chooser dialog. 

 

If you have more than one position to draw, please delimit the positions with 

semicolons. There are three different display ways based on the number of the 

positions. 

 

 One position 

Without shape  

With shape  

 

 Two positions 

Without shape  
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With shape  

 

 Three positions 

Without shape  

Without shape  

 

You can use the mouse to drag the text to a proper position in the canvas. If you want 

to relocate the functional sites, you just need to simply drag the callout lines to a new 

position. 

 

Use the Show Position check box to set the line display with or without position text. 
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Add Cutline 

When you click the CutLine button or choose Edit -> Add CutLine in both protein 

and nucleotide mode interface, a cutline property dialog box will appear as shown 

below: 

 

The right area of the property dialog box contains the following settings for the 

cutline: 

 

1. The ID panel 

ID: A unique ID can be indicated for the cutline in this textfield. When the cutline 

is created, a default ID value will be automatically indicated. Users are allow to 

modify the default value. When inputting a new value, the characters will turn 

black from gray. 

 

2. The location panel 

Position: Specify the exact position of a cutline. 

Width: Specify the width of a cutline. 

Height: Specify the height of a cutline. 

 

3. The style panel 

Parallel Line: Select the style of a cutline. There are four selectable options, 

including Line-left, Line-right, Curve-Left and Curve-right. 
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Protein dash or Nucleotide dash: Select the direction of dashed shear line on 

protein or nucleotide. 

 or  

Left   

Right  

 

4. The border panel 

Line size: Select the thickness of the parallel line. 

Line Color: Select the color of the parallel line. 

 

Add Note 

When you click the Note button or choose Edit -> Add Note, a note property dialog 

box will appear as shown below. Alternatively, click on the Note command  in 

the shape toolbar will also open the note property dialog box.  
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The right area of the property dialog box contains the following settings for the note: 

 

1. The ID panel 

ID: A unique ID can be indicated for the note in this textfield. 

 

2. The text panel 

Text: Specify text of the note. 

 

3. The style panel 

Font Size: Specify font size of the text. 

Text color: Specify color of the text. 

Font Style: Select font style of the text, including Bold, Italics and Plain. 

Font: Select font type of the text. 

 

4. The location panel 

Central X: Specify the x coordinate of the note. 

Central Y: Specify the y coordinate of the note. 

Angle: Specify the rotation angle of the note. 

 

7. The border panel 

Line size: Change the border size of the current note. 

Dash: A checkbox for altering the border line into dash line. 

Line color: Select a color for the border line from the chooser dialog. 
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Note: You can use the mouse to drag the text to a proper position in the canvas. 

 

Add Marker 

When you click on the Marker command  in the shape toolbar, a marker 

property dialog box will appear as shown below: 

 

The right area of the property dialog box contains the following settings for the 

marker: 

 

1. The ID panel 

ID: A unique ID can be indicated for the marker in this textfield. 

 

2. The location panel 

Central X: Specify the x coordinate of the marker. 

Central Y: Specify the y coordinate of the marker. 

Width: Specify the width of the marker. 

Height: Specify the height of the marker. 

 

3. The text panel 
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Name: Specify the name of marker. 

Location: Specify the position of the text. 

Font Size: Specify the font size of the text. 

Text Color: Specify the color of the text. 

 

4. The style panel 

Shape: With the shape combo box, users are allow to select various polygon 

elements for marker. 

Rotation Angle: Specify the rotation angle of the marker. 

Shape Color: Select a color for the current marker from the chooser dialog. If the 

default check box is selected, the software will assign a default color for the 

marker.  

Gradient: Select a color gradient for the current marker. 

Texture: Select a texture for the current marker. 

 

5. The border panel 

Line size: Change the border size of the current marker. 

Dash: A checkbox for altering the border line into dash line. 

Line color: Select a color for the border line from the chooser dialog. 

 

Note: Use the text Location combo box to set the name of domain display above, 

under or inside the domain or not display at all. 

 

Center:  

Up:  

Down:  
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Hide:  

 

Add Bracket 

When you click on the Bracket command  in the shape toolbar, a marker 

property dialog box will appear as shown below: 

 

The right area of the property dialog box contains the following settings for the 

bracket: 

 

1. The ID panel 

ID: A unique ID can be indicated for the marker in this textfield. 

 

2. The location panel 

Central X: Specify the x coordinate of the bracket. 

Central Y: Specify the y coordinate of the bracket. 

Width: Specify the width of the bracket. 

 

3. The style panel 

Rotation Angle: Specify the rotation angle of the bracket. 

Type: Select the type of bracket. The following types are provided: 

Brace  
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Square Bracket  

Color: Select a color for the current bracket from the chooser dialog.  

Line size: Change the thickness of the current bracket. 

 

Add Straight Line 

When you click on the Straight Line command  in the shape toolbar, a straight 

line property dialog box will appear as shown below: 

 

The right area of the property dialog box contains the following settings for the 

straight line: 

 

1. The ID panel 

ID: A unique ID can be indicated for the straight line in this textfield. 

 

2. The position panel 

X1 and Y1: Specify the start position of the straight line. 

X2 and Y2: Specify the end position of the straight line. 

 

3. The stroke panel 

Line size: Change the thickness of the current straight line. 

Dash: A checkbox for altering the straight line into dash line. 

Line color: Select a color for the straight line from the chooser dialog. 

Style: Select the style of straight line. There are five styles of line provided: 
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1) Line  

2) Arrow  

3) Double arrow  

4) Scale  

5) Scale arrow  

Add curve 

When you click on the Curve command  in the shape toolbar, a curve property 

dialog box will appear as shown below: 

 

The right area of the property dialog box contains the following settings for the curve: 
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1. The ID panel 

ID: A unique ID can be indicated for the curve in this textfield. 

 

2. The position panel 

X1 and Y1: Specify the start position of the curve. 

X2 and Y2: Specify the end position of the curve. 

 

3. The stroke panel 

Line size: Change the thickness of the current curve. 

Dash: A checkbox for altering the curve into dash line. 

Line color: Select a color for the curve from the chooser dialog. 

Style: Select the style of curve. Similar to straight line, there are five styles 

provided in the style combo box.  

 

Add Bezier Curve 

When you click on the Bezier Curve command  in the shape toolbar, a Bezier 

curve property dialog box will appear as shown below: 

 

The right area of the property dialog box contains the following settings for the Bezier 

curve: 

 

1. The ID panel 

ID: A unique ID can be indicated for the Bezier curve in this textfield. 

 

2. The position panel 
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X1 and Y1: Specify the start position of the Bezier curve. 

X2 and Y2: Specify the end position of the Bezier curve. 

 

3. The stroke panel 

Line size: Change the thickness of the current Bezier curve. 

Dash: A checkbox for altering the Bezier curve into dash line. 

Line color: Select a color for the Bezier curve from the chooser dialog. 

Style: Select the style of Bezier curve. Similar to straight line, there are five styles 

provided in the style combo box. 

 

Add Polyline with One Knuckle Point 

When you click on the Polyline with One Knuckle Point command  in the shape 

toolbar, a polyline property dialog box will appear as shown below: 

 

The right area of the property dialog box contains the following settings for the 

polyline: 

 

4. The ID panel 

ID: A unique ID can be indicated for the polyline in this textfield. 

 

5. The position panel 

X1 and Y1: Specify the start position of the polyline. 

X2 and Y2: Specify the end position of the polyline. 

 

6. The stroke panel 

Line size: Change the thickness of the current polyline. 
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Dash: A checkbox for altering the polyline into dash line. 

Line color: Select a color for the polyline from the chooser dialog. 

Style: Select the style of polyline. Similar to straight line, there are five styles 

provided in the style combo box. 

 

Add Polyline with Two Knuckle Points 

When you click on the Polyline with Two Knuckle Points command  in the 

shape toolbar, a polyline property dialog box will appear as shown below: 

 

The right area of the property dialog box contains the following settings for the 

polyline: 

 

1. The ID panel 

ID: A unique ID can be indicated for the polyline in this textfield. 

 

2. The position panel 

X1 and Y1: Specify the start position of the polyline. 

X2 and Y2: Specify the end position of the polyline. 

 

3. The stroke panel 

Line size: Change the thickness of the current polyline. 

Dash: A checkbox for altering the polyline into dash line. 

Line color: Select a color for the polyline from the chooser dialog. 

Style: Select the style of polyline. Similar to straight line, there are five styles 

provided in the style combo box. 
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Canvas Size 

Choose the Edit -> Canvas size can open a canvas size property dialog box. 

 

Width: Set the width of current canvas (pix). 

Height: Set the height of current canvas (pix). 

Keep width-height ratio check box: Keep the width-height ratio when setting the 

canvas. 

 

Mouse operation 

For convenience, we add new functions of mouse operation in IBS 1.0. Here, we used 

an instance from G. Liang’s work to depict the usage. 
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1. Selecting and Dragging 

When clicking on an element, such as protein or nucleotide sequence, shaped site, 

marker or domain (in nucleotide mode), four yellow anchor points and a red anchor 

point will appear around the element. You can drag the yellow anchor points to 

change the size of the element, or drag the red anchor point to rotate the element. 

Notably, protein, nucleotide and text cannot be zoom in and zoom out by mouse 

dragging. Besides, to move the element, you should not place the mouse on the 

anchor points. 

Here we present three particular examples to further illustrate the selecting and 

dragging of drawing elements.  

 

The selecting and dragging of nucleotide domains 

When clicking on the domain in nucleotide diagram, several yellow anchor points 

appear. By dragging the yellow anchor points, the corresponding domain can be 

zoomed in and out. Likewise, to change the angle of a domain, you just need to rotate 

the red anchor points. The effects are shown below: 
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The selecting and dragging of bracket elements 

When clicking on the bracket elements, three anchor points appear. You can drag the 

blue anchor to adjust the length of the bracket. Also, by dragging of the red anchor, 

you can rotate the bracket around the yellow anchor. 
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The selecting and dragging of line elements 

After selecting the line elements, blue anchor points will appear on both ends of the 

line. When dragging any of the anchor points, you can relocate the endpoint of your 

line. 

 

Before dragging 

  

 

After dragging 

  

 

If you draw a curve or one-knuckle-point polyline, there will be a red control point in 

the middle of the line. When you drag the red point, the shape of the curve or polyline 

will be changed. 

 

Before dragging 

 

 

After dragging 
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Curve  

Polyline  

 

If you draw a Bezier curve or two-knuckle-point polyline, there will be two control 

point in the middle of the line. When you drag any of the control point, the shape of 

the curve or polyline will be changed. 

 

Before dragging 

 

 

After dragging 

Curve  

Polyline  
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2. Double-clicking of mouse 

When double-clicking the drawing elements, a property dialog box will appear as 

shown below. From the property dialog, you can edit the appearance of drawing 

elements. The below picture shows an example of editing a functional domain in 

Kdm2a.  

 

 

Keyboard operation 

1. After to selecting an element (except protein or nucleotide sequences ) by mouse 

clicking, you can press "→" to move left, "←" to move right, "↑" to move up 

(except the functional domain) or "↓"to move down (except the functional 

domain). 

2. Press “Del” to delete a selected element (including protein and nucleotide 

sequences). 

3. After selecting a polygon marker by mouse clicking, you can press "Ctrl+→" to 

enlarge the width, “Ctrl+←” to narrow the width, “Ctrl+↑” to enlarge the height 

or “Ctrl+↓” to reduce the height. 

4. Press “Ctrl+C” and “Ctrl+V” to duplicate the drawing element (including protein 

and nucleotide sequences). 
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5. Mouse-clicking on the starting points of our five different kinds of line elements, 

simultaneously, pressing the “Ctrl+-“, you can put the starting point horizontally 

as shown below. 

 

Before pressing “Ctrl+-“ 

 

 

After pressing “Ctrl+-“ 

 

 

6. Similarly, mouse-clicking on the starting points of our five different kinds of line 

elements, simultaneously, pressing the “Ctrl+|“, you can put the starting point 

vertically as shown below. 

 

Before pressing “Ctrl+|” 

 

 

 After pressing “Ctrl+|” 
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7. Mouse-clicking on the knuckle points of a polyline and pressing the “Ctrl+R” 

simultaneously, you can change the angle to 90° as shown below: 

 

Before pressing “Ctrl+R” 

 
 

After pressing “Ctrl+R” 

 

 

8. Press “Ctrl+U” to undo the current operation. 

9. Press “Ctrl+E” to redo the latest operation. 
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Release Note 

1. Feb. 2nd, 2008, the final packages of online demo and local stand-alone softwares 

of DOG 1.0 are released.  

2. Mar. 25th, 2008, a bug on opening project was found and fixed.  

3. Apr. 19th, 2008, Dr. Fernan Aguero (San Martin, Argentina), had contacted and 

reminded us that our software could not be installed or worked under Linux/Unix 

systems. We have re-complied the package of DOG 1.0 for Linux/Unix to fix the 

bug.  

4. May 18th, 2008, a new function of “Mouse-clicking” was added in the software. 

And the figure format was extended to be exported in JPEG format. 

5. Aug. 28th, 2008, rebuild the GUI with NetBeans 6.1. 

6. Jan. 3rd, 2009, DOG version 1.0.3 was released. We fixed a bug that cannot create 

a new file under Mac OS X. The Acknowledgement list and contact information 

were added into the new version.  

7. Jan. 19th, 2009 ， DOG web server was moved to new website 

(http://dog.biocuckoo.org) and a new GPS logo was put into use.  

8. Apr. 7th, 2009, DOG version 1.0.4 was released. The DOG image can be exported 

in TIFF format with 300 or 600dpi. Image Format was added in Tools menu.  

9. Jun. 10th, 2009, DOG version 1.0.5 was released. Express the domain length with 

relative length instead of absolute length.  

10. Jan. 6th, 2011, DOG 2.0 beta version released. The new version supports 

multi-protein display and SVG (Scalable Vector Graphics) image output.  

11. Nov. 6th, 2011, the DOG 2.0 beta version was released. In contrast to the previous 

version of DOG, the new version supports more functions, including multi-protein 

display, SVG (Scalable Vector Graphics) image output, canvas resize and draw 

line or arrow. 

12. Aug. 24th, 2014, the IBS 1.0 was released. In IBS 1.0, a brand new dual-mode 

user interface was developed for supporting both protein and nucleotide 

presentation. We have also designed various drawing elements for the purpose of 

providing an unconstrained drawing environment to users. To help users prepare 

diagram in a more aesthetic and concise appearance, three professional renderers 

were implemented in IBS. 

13. Nov. 17th, 2015, the IBS 1.0.1 was released. The new version has optimized the 

batch export function and reduced memory footprint. Besides, a command line 

export module was also added for the mass generation of IBS images. 


